FIX NODEJS LEGACY NPM PROBLEMS IN UBUNTU

Very common in debian which gives the following error message when trying to run npm install: “WARN This failure might be due to the use of legacy binary “node” npm WARN For further explanations, please read /usr/share/doc/nodejs/README.Debian” .

Install nodejs-legacy to fix the problem

sudo apt-get install nodejs-legacy

For more information, see the stackoverflow answer: http://stackoverflow.com/a/21171188

Add your comment